Fortaleza Digital


Hola a todos
agosto 13, 2011, 11:53 am
Filed under: Sin categoría

Hola! pronto nuevos temas sobre CISCO, pero desde la siguiente URL:

http://www.redescisco.cl

Los espero a todos alla, Saludos!



Videotutorial de VLSM
marzo 22, 2009, 5:50 pm
Filed under: Videotutoriales | Etiquetas:

Encontre una coleccion de Videoturiales sobre configuracion de routers Cisco,entre los temas estan Vlan, ACL’s, EIGRP,OSPF,DNS, DHCP, etc.
Aqui subi el primero sobre VLSM (Mascaras de Logitud Variable) de casi 1 hora de duración , pronto ire subiendo más. ;)



Protocolos de Enrutamiento,Parte 3: Enrutamiento Dinamico con RIP
marzo 21, 2009, 5:38 am
Filed under: Routing | Etiquetas: , , , , ,

RIP, es un protocolo de enrutamiento Dinámico de vector distancia, esto quiere decir que su metrica para llegar a una red destino se basa en el numero de saltos.
Es un protocolo abierto a diferencia de por ejemplo IGRP y EIGRP que son propietarios de Cisco.Es relativamente simple ideal para redes pequeñas, el numero de saltos maximo hacia un destino es 15 (cuando hablo de numero de saltos , me refiero a la cantidad de routers , por la que tiene que atravesar el paquete para llegar a destino), ya con 16 la red se declara como inalcanzable.
Existen dos versiones de este protocolo version 1 y 2, la diferencia más importante, es que RIP v1 es lo que se llama un Protocolo con clase, lo que significa que cuando cuando publica las tablas de enrutamiento, este no adjunta las mascaras de subred.
En cambio Rip v2 es un Protocolo sin clase, que si adjunta la mascara de subred, por lo que permite el uso de VLSM, CIDR, sumarización.
Otra diferencia es que RIP v1 publica sus actualizaciones en forma de Broadcast, es decir a todos los equipos de la red, mientras que RIP v2 lo hace en modo de Multicast, es decir solo a un grupo de host de una red.
Resumiendo las caracteristicas de las 2 versiones:

RIP Versión 1:
– Protocolo Abierto
– Distancia Administrativa:120
– Protocolo con clase
– Metrica numero de saltos
– Actualizaciones cada 30 segundos
– Envía las Actualizaciones en forma de Broadcast
– Numero Maximo de Saltos 15
– Red Destino Inalcanzable, se declara como 16 saltos
– No Permite VLSM, CIDR

RIP Versión 2 :
En lo que difiere es lo siguiente, porque lo demas es lo mismo que el version 1 :
– Protocolo sin clase
– Envía las Actualizaciones en forma de Multicast (224.0.0.9)
– Permite VLSM, CIDR.

Ejemplo Practico de como “levantar” RIP

En Router0

router0>enable
router0#configure terminal
router0(config)#router rip
router0(config)#version 2
router0(config-router)#network 10.0.0.0
router0(config-router)#network 150.150.0.0

En Router1

router1>enable
router1#configure terminal
router1(config)#router rip
router1(config)#version 2
router1(config-router)#network 200.100.100.0
router1(config-router)#network 150.150.0.0

Una explicación de los comandos, se utiliza el comando router en modo configuración global, que es usado para implementar cualquier protocolo de enrutamiento.
Luego se especifica la version , en este caso yo implemente la version 2 , si no se especifica se configura en la version 1 que es la por defecto, y por ultimo se utiliza el comando network en sub-modo de protocolo de enrutamiento, en donde se ingresan las redes directamente conectadas al router, y son las que seran publicadas por RIP.



Protocolos de Enrutamiento, Parte 2: Enrutamiento Estático
septiembre 26, 2008, 4:41 am
Filed under: Routing | Etiquetas: , , ,

Como había dicho en la parte 1, el enrutamiento estático, es creado manualmente
a diferencia de los protocolos dinámicos, que se intercambian las tablas de enrutamiento mediante actualizaciones períodicas.
Para crear una ruta estática, es en modo configuración global, y el comando IOS es el siguiente

ip route [ip red destino][mascara de subred][ip siguiente salto]

ejemplo: router(config)#ip route 200.0.0.0 255.255.255.0 130.0.0.2

o también puede ser;

ip route [ip red destino][mascara de subred][interfaz de salida]

ejemplo: router(config)#ip route 200.0.0.0 255.255.255.0 s0/2

* Interfaz de salida, se refiere a la interfaz del router local, que esta conectado a las redes externas

Rutas Estaticas por Defecto

Las rutas estáticas por defecto, son una ruta estática especial, se crean para enrutar el trafico de internet, ya que es imposible crear rutas a hacia las redes que estan en internet.

¿Y cómo funcionan?

Cualquier ip de una red destino que el router no tenga ninguna coincidencia en su tabla de enrutamiento, este ocupará la ruta por defecto y mandara el paquete hacia donde se le indicó en esta. Las rutas estáticas por defecto también se crean en modo configuración Global.

La estructura es la siguiente:

ip route 0.0.0.0 0.0.0.0 [ip interfaz siguiente salto]

Ejemplo:router(config)#ip route 0.0.0.0 0.0.0.0 120.0.0.2

o tambien puede ser;

ip route 0.0.0.0 0.0.0.0 [interfaz de salida]

Ejemplo: router(config)#ip route 0.0.0.0 0.0.0.0 s0/1

Ejemplo Practico

Topologia a utilizar para enrutamiento estático

Configurando Router Antofagasta

En este router voy a aplicar una ruta estática por defecto, ya que siempre los paquetes van a tener una salida que es el router santiago, por lo tanto , cualquiera que sea la ip de la red destino esta ruta por defecto la enviara hacia dicho router, bien vamos con la configuración.

antofa>enable
antofa#configure terminal
antofa(config)#ip route 0.0.0.0 0.0.0.0 200.100.100.2

Aqui ya he creado la ruta por defecto, en mi caso estoy acostumbrado a ocupar la ip del salto siguiente (200.100.100.2),pero tambien en vez de esa ip podria haber ido ahi la interfaz local del router antofagasta en este caso la serial serial0/0. Si vemos la tabla de enrutamiento del router antofagasta, con el comando show ip route veremos lo siguiente:


antofa>enable
antofa#show ip route
C    172.16.0.0/16 is directly connected, FastEthernet0/0
C    200.100.100.0/24 is directly connected, Serial0/0
S*   0.0.0.0/0 [1/0] via 200.100.100.2

Las rutas que tienen una “C”, son las interfaces directamente conectadas al router, y la “S*”, indica que es una ruta estática por defecto, que es la ruta que creamos, por lo tanto cualquier paquete hacía una ip destino que el router no tenga en esta tabla de enrutamiento, lo enviara hacía la interfaz 200.100.100.2.

Configurando Router santiago

Este router tendrá que tener una ruta estática para saber llegar tanto a la LAN de router antofagasta como la de concepcion.

Vamos a crear la configuracion:

stgo>enable
stgo#configure terminal
stgo(config)#ip route 172.16.0.0 255.255.0.0 200.100.100.1
stgo(config)#ip route 190.60.0.0 255.255.0.0 220.0.10.1

He creado las 2 rutas estaticas:

La primera es para llegar a la LAN  del router antofagasta (IP 172.16.0.0/16), que saldrá por la ip de la interfaz del salto siguiente osea 200.100.100.1(Teniendo en cuenta que estamos parados en el router santiago).

La segunda es para llegar a la LAN  del router concepcion (IP 190.60.0.0/16), que saldrá por la ip de la interfaz del salto siguiente osea 220.0.10.1 (Teniendo en cuenta que estamos parados en el router santiago).

Si aplicamos el comando show ip route en modo de privilegio.  veremos:
stgo>enable
stgo#show ip route

C    120.0.0.0/8 is directly connected, FastEthernet0/0
S    172.16.0.0/16 [1/0] via 200.100.100.1
S    190.60.0.0/16 [1/0] via 220.0.10.1
C    200.100.100.0/24 is directly connected, Serial0/0
C    220.0.10.0/24 is directly connected, Serial0/1

Vemos la ip de la 3 interfaces conectadas directamente, y también las rutas estaticas creadas para que el router santiago “sepa”  llegar a las Lan de antofagasta y concepcion.

Configurando Router concepcion
Po último nos queda configurar el router concepcion, que es el mismo caso del router antofagasta, osea una ruta por defecto, ya que siempre va a tener como salida el router santiago, por lo tanto con la ruta por defecto le decimos que cualquier ip que no conozca la envíe hacia el router santiago

La configuracion sería:

conce>enable
conce#configure terminal
conce(config)#ip route 0.0.0.0 0.0.0.0 220.0.10.2

Y para ver la tabla de enrutamiento:

conce>enable
conce#show ip route


C 190.60.0.0/16 is directly connected, FastEthernet0/0
C 220.0.10.0/24 is directly connected, Serial0/1
S* 0.0.0.0/0 [1/0] via 220.0.10.2

Ya con esto todos los routers conocen sus LAN.
A modo de ejemplo voy a hacer un tracert (comando para hacer el seguimiento de todos los routers por los que pasa un paquete), desde PC5 que esta en la LAN de concepcion a PC0, que se encuentra en la LAN del router antofagasta y cuya ip es 172.16.0.2, en donde se puede ver las interfaces por las que pasa el paquete en los routers.



Protocolos de Enrutamiento: Parte 1
septiembre 23, 2008, 10:11 pm
Filed under: Routing | Etiquetas: , ,

Los protocolos de enrutamiento permiten a los routers poder dirigir o enrutar los paquetes hacia diferentes redes usando tablas.

Existen protocolos de enrutamiento estático y dinámicos.

Protocolo de Enrutamiento Estático: Es generado por el propio administrador, todas las rutas estáticas que se le ingresen son las que el router “conocera”, por lo tanto sabrá enrutar paquetes hacia dichas redes.

Protocolos de Enrutamiento Dinámico: Con un protocolo de enrutamiento dinámico, el administrador sólo se encarga de configurar el protocolo de enrutamiento mediante comandos IOS,en todos los routers de la red y estos automaticamente intercambiarán sus tablas de enrutamiento con sus routers vecinos, por lo tanto cada router conoce la red gracias a las publicaciones de las otras redes que recibe de otros routers.

Esquema de publicación de tablas de enrutamientoPublicación de tablas de enrutamiento entre dos Routers, configurados con un protocolo dinámico

Antes de hablar sobre la clasificación de los protocolos de enrutamiento dinámicos, es necesario de hablar de un concepto llamado Métrica.
La métrica es el analisis, y en lo que se basa el algoritmo del protocolo de enrutamiento dinámico para elegir y preferir una ruta por sobre otra,basandose en eso el protocolo creará la tabla de enrutamiento en el router,publicando sólo las mejores rutas .

Los protocolos de enrutamiento dinámicos se clasifican en:

-Vector Distancía
-Estado de Enlace

Vector Distancia: Su métrica se basa en lo que se le llama en redes “Numero de Saltos”, es decir la cantidad de routers por los que tiene que pasar el paquete para llegar a la red destino, la ruta que tenga el menor numero de saltos es la mas optima y la que se publicará.

Estado de Enlace: Su métrica se basa el retardo ,ancho de banda , carga y confiabilidad,de los distintos enlaces posibles para llegar a un destino en base a esos conceptos el protocolo prefiere una ruta por sobre otra.Estos protocolos utilizan un tipo de publicaciones llamadas Publicaciones de estado de enlace (LSA),que intercambian entre los routers, mediante estas publicación cada router crea una base datos de la topología de la red completa.

Algunos protocolos de enrutamiento dinámicos son:

RIP : Protocolo de enrutamiento de gateway Interior por vector distancia.

IGRP: Protocolo de enrutamiento de gateway Interior por vector distancia, del cual es propietario CISCO.

EIGRP: Protocolo de enrutamiento de gateway Interior por vector distancia, es una versión mejorada de IGRP.

OSPF: Protocolo de enrutamiento de gateway Interior por estado de enlace.

BGP: Protocolo de enrutamiento de gateway exterior por vector ditancia.

El concepto de Gateway Interior o Exterior, se refiere a que si opera dentro de un sistema Autonomo o fuera de el. Un sistema Autonomo, puede ser una organización que tiene el todo el control de su red, a estos sistemas autonomos se le asigna un numero de Identificación por el ARIN (Registro Estadounidense de numeros de Internet), o por un proveedor de servicios. Los protocolos de enrutamiento como IGRP y EIGRP, necesitan de este numero al momento de configurarse.

El protocolo BGP es de gateway exterior, es decir se encuentra fuera de los sistemas autonomos, generalmente entre los que se les llama routers fronterizos entre ISP’s, o entre una compañia y un ISP, o entre redes que interconectan paises.

Esquema de Protocolos de Enrutamiento

Esquema de Protocolos de Enrutamiento


Documento con comandos Cisco IOS, para configurar Routers
septiembre 2, 2008, 2:23 am
Filed under: Descargas | Etiquetas: , ,

Dejo este documento PDF, que contiene una gran cantidad de comandos IOS necesarios para configuracion de Routers Cisco, en cada comando hay una descripción de para que sirve, y se indica en el modo EXEC en el que se ejecutan ya sea usuario, Privilegio, o configuracion global, tambien los sub modos de configuracion global, ya sea de interfaz , de protocolo, de linea, un muy buen documento que conviene tener a mano para consulta, y sirve como guia para los que se inician en la configuración de routers.

Descarga

Descarga



Dar un nombre a un router y asignación de IP a Interfaces mediante comandos IOS
agosto 28, 2008, 3:15 am
Filed under: Routing | Etiquetas: ,

Voy a poner un ejemplo con una topología bastante sencilla en el cual utilizo un router cisco 1841, que contiene 2 Lan, una con una ip 10.0.0.0/8 tipo A, y otra con una clase C que es la 172.16.0.0 /16, las 2 con mascaras de subred por defecto. La idea es darle un nombre al router y configurar sus interfaces fast ethernet y que queden activas para el enrutamiento de paquetes ip.

Topologia a utilizar

Topología a utilizar


Vamos al primer paso: Asignacion de un nombre al Router

Hacemos doble click en packet tracer sobre el router y entramos al CLI (Interfaz de Linea de Comandos).

Nos va a aparecer , un asistente para la configuración, salimos de ese modo de asistente colocando control C, nos va a decir que presione enter o return

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]:

Router>enable
Router#configure terminal
Router(config)#hostname informatica
informatica(config)#exit
informatica#wr

Una vez que hacemos eso entramos al modo usuario del router, y el prompt quedara de la siguiente forma con el nombre del router por defecto y un signo “mayor a”
entramos al modo de Privilegio colocando el comando enable, y presionamos enter.

Ya en el modo Privilegio el Prompt cambia a el nombre del router con un #, y colocamos el comando configure Terminal, para entrar al modo de configuración global (se pueden escribir las primeras 3 o 4 letras del comando ,y se presiona la tecla TAB, asi se completa el resto del comando automaticamente sin necesidad de escribir todo).

Una ves que entramos al modo de configuración global, aplicamos el comando que nos servira para dar el nombre al router el comando es Hostname seguido del nombre que le vamos a dar en este caso yo le puse informatica, presionamos enter y automaticamente cambia el promt con el nombre que le dimos.

Salimos de modo de configuración global mediante exit, y volvemos al modo privilegio (también se puede volver de manera directa colocando control Z), una vez ahi grabamos en la NVRAM con el comando wr., y eso es todo hemos cambiado el nombre por defecto del router por uno más especifico.

Vamos al segundo Paso : Asignación de Ip y activación de Interfaces

informatica(config)#interface f0/0
informatica(config-if)#ip address 172.16.0.1 255.255.0.0
informatica(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
informatica(config-if)#

Siguiendo con el mismo ejemplo, nos ubicamos en el modo configuración global, y colocamos el comando interface seguido de la interfaz especifica a configurar en este caso las fast ethernet 0/0y presionamos enter.

Ahora estamos dentro de un sub modo de configuracion global,cambia el prompt a informatica(config-if)#

y le damos la ip y mascara la interfaz mediante el comando ip address [ip] [mascara de subred], presionamos enter.

Y luego la activamos (las interfaces vienen desactivadas por defecto), mediante comando no shutdown, lo demas nos indica que la interfaz esta “arriba”, eso es todo para la asignacion de ip a una interfaz de un router cisco, para configurar la otra LAN es exactamente lo mismo, obviamente con las ip que correspondan a ese segmento,a qui van los comandos de la otra lan

informatica(config)#interface f0/1
informatica(config-if)#ip address 10.0.0.1 255.0.0.0
informatica(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
informatica(config-if)#




Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.